We have stopped seeing the increased timeouts and are still awaiting on Chase's investigation results.
Posted Jan 09, 2026 - 17:45 UTC
Update
Chase teams are continuing to investigate.
Posted Jan 09, 2026 - 17:05 UTC
Update
Chase teams are continuing to investigate.
Posted Jan 09, 2026 - 17:04 UTC
Update
Chase teams are continuing to investigate.
Posted Jan 09, 2026 - 15:21 UTC
Investigating
We have seen an increase in timeouts that could be affecting some merchants under Chase. We have escalated this to Chase and their teams have acknowledged that they are further investigating. We are still and have been seeing successful traffic as well.