PaymentechChase Circuit Breaker 6/3/2025 8:48A

Incident Report for Apriva Gateway

Resolved

This incident has been resolved
Posted Jun 03, 2025 - 16:30 UTC

Investigating

PaymentechChase has consecutive failed transactions that exceeds the alert value
Posted Jun 03, 2025 - 15:48 UTC
This incident affected: Processors.