Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 04, 2025 - 02:00 UTC
Scheduled
We will be undergoing scheduled maintenance for connections to Chase Paymentech on October 3rd at 10 PM EDT. There will be brief interruptions to the processor during the scheduled time.
Posted Sep 22, 2025 - 17:12 UTC
This scheduled maintenance affected: Gateway and Processors.